Overview
All activity logging prior to a specific date is missing in the Logs Browser and Activity Log. However, the events can be found in the GFI EndPointSecurity Windows event log on the agent machines.
Environment
- GFI EndPointSecurity
- All supported environments
Root Cause
The events have either been moved to the backup database or deleted according to the database maintenance tasks configured.
Resolution
- Open the GFI EndPointSecurity Console.
- Go to Configuration > Options > Database Backend.
- Click Database Maintenance.
- If the Backup events older than the specified period option is selected, then the events can be found in the EndPointSecurity backup database.
- If the Delete events older than the specified period option is selected, then the events have been deleted from the database and cannot be recovered.