Overview
When deploying an agent or agents, the following error is displayed in the deployment history:
Failed to contact remote computer. Computer might be offline...
Environment
- GFI EndPointSecurity
- All Supported Environments
Root Cause
Network configuration issues prevent GFI EndPointSecurity from resolving IP addresses correctly.
Resolution
- From the GFI EndPointSecurity machine, ping the computer by hostname and take note of the IP Address returned.
- On the target computer, determine the current IP Address using the
ipconfig
command. - If the two IP addresses do not match, this is the source of the issue. Try the following:
- From the GFI EndPointSecurity machine's command prompt, run the command:
Nslookup <Target_Computer_Name>
and see if the returned IP address matches the IP Address returned in step #2 above. If the IP Addresses are different, it is confirmed that the local DNS server does not have the correct IP Address registered for the target machine.
- From the GFI EndPointSecurity machine's command prompt, run the command:
- To address this, run the following commands on the target machine:
ipconfig /release
ipconfig /renew
ipconfig /registerdns
Notes:
- Any errors in the
registerdns
process may take up to 15 minutes to show up in the client computer's Event Log. - If #3 fails to fix the issue, troubleshoot the issue of DNS / DHCP registrations on your network.