Overview
When importing configuration from file or folder, it produces the following error:
The selected file does not have the correct format
Environment
- GFI EndPointSecurity
- All Supported Environments
Root Cause
An empty or corrupt toolcfg_updates.xml in the Data folder of the EndPointSecurity commonly causes this issue.
Example of an empty toolcfg_updates.xml section in the configuration backup file:
<XMLFileInfo>
<RelativeName>toolcfg_updates.xml</RelativeName>
<XmlData />
</XMLFileInfo>
Example of a corrupt toolcfg_updates.xml section in the configuration backup file:
<XMLFileInfo>
<RelativeName>toolcfg_updates.xml</RelativeName>
<XmlData>
����T��������
���`���������
h�������������
�������;�������
��������p����
�������������
�������������
������������
</XmlData>
</XMLFileInfo>
If importing from a Data folder, check for any corrupt or empty XML files.
Resolution
To resolve the error detailed previously, follow the steps listed below:
- Open the configuration backup file with a Text Editor.
- Check if any of the EndPointSecurity configuration files listed contain corrupt or missing data.
- Remove the corrupt section from the configuration backup file and save changes.